Do I need the library package ?

If you use Arduino IDE, yes. You should download this package and keep it up-to-date manually.
The package is a zip file which must be manually unpacked in Arduino Libraries folder (usually it's under sketchbook one, named 'libraries').
Do NOT use the zip installer from Arduino IDE, and do NOT put the whole ZIP file inside libraries folder; you must unzip it.

If you use the FishIDE IDE, you DON'T need this package; Fishino libraries are automatically managed and updated by it.

Just remember : usually each firmware version has its own library set; if you use a new library version with an old firmware or the way around probably nothing will work!
So, ALWAYS download latest libraries AND update the board's firmware to latest version!

Which libraries version ?

As said in previous paragraph, the best is to use the latest library version along with latest firmware version.

Sometimes it's possible that something stops working when updating, or that we change something that is not compatible with your old sketch.
To make even oldest projects work as before, from now we will also provide previous library versions with a note on which firmware version they belong.
So, if you want to downgrade it you can, just check that library and firmware versions match!

2017_10_09 - Fishino-Libs - For firmware version 7.0.x
2017_08_02 - Fishino-Libs - For firmware version 7.0.x